Rebuy Admin Portal Navigation Issues

Incident Report for Rebuy

Resolved

All reported navigation issues have been resolved at this time.
Posted Sep 01, 2026 - 11:50 EDT

Monitoring

A fix has been implemented and the navigation issues appear to have been resolved. We are testing and monitoring to confirm there is no further impact.
Posted Sep 01, 2026 - 11:43 EDT

Investigating

We are currently investigating issues with navigating within the Rebuy admin portal. All on-site functionality remains in-tact at this time.
Posted Sep 01, 2026 - 11:34 EDT
This incident affected: Core (Admin Portal).