New Resource Creation Issues

Incident Report for Rebuy

Postmortem

Description:

On February 18th, between 12:44 PM and 1:44 PM EST, merchants may have experienced errors when attempting to create new configurations within the Rebuy platform. Affected actions included the creation of Smart Carts, Checkout Extension Widgets, Merchandising Widgets, Bundle Builder, Smart Flows, and Monetize Widgets. The disruption lasted approximately 60 minutes. Read operations and existing store configurations were not impacted, meaning no storefront disruptions occurred for active merchants, and no data was lost or corrupted.

Root Cause:

A planned platform deployment unintentionally introduced a dependency update that conflicted with how our system handles certain create and update operations, causing those requests to fail.

Resolution:

Our engineering team identified the root cause and deployed a targeted fix within the same deployment window, restoring full service by 1:44 PM EST.

Posted Feb 19, 2026 - 13:24 EST

Resolved

All tests are showing positive results. This issue has been resolved.
Posted Feb 18, 2026 - 14:05 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 13:49 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 18, 2026 - 13:32 EST

Investigating

We're currently aware of an issue that may temporarily affect the ability to create new Smart Carts, Smart Flows, Widgets, Bundle Builder, Monetize or add new packages. Our team is actively working to resolve this as quickly as possible.

All existing configurations and on-site tooling remain fully functional. No action is needed on your end.

We'll provide an update once everything is back to normal. Thank you for your patience!
Posted Feb 18, 2026 - 13:15 EST
This incident affected: Cart & Merchandising (Smart Cart, Merchandising Widgets, Bundle Builder), Checkout & Post-Purchase (Checkout Extensions Widgets, Post-Purchase Offers, Thank You Page / Order Status Page Widgets), Flows & A/B Testing (Smart Flows), and Rebuy Monetize.