Degraded Admin Experience (Saving Changes Errors)

Incident Report for Rebuy

Resolved

The issue has been resolved at this time. Apologies for the inconvenience!
Posted Jun 18, 2025 - 14:35 EDT

Monitoring

We've identified the issue and implemented a fix to reduce its impact.
Posted Jun 18, 2025 - 14:32 EDT

Investigating

We’re currently looking into an issue where changes made in the admin are showing an error, even though they’ve been successfully saved. In the meantime, simply refresh the page, and you should see the changes you made. We're actively working on fixing the inaccurate error message. Thanks for your patience!
Posted Jun 18, 2025 - 14:13 EDT
This incident affected: Admin Portal.