Rebuy Admin Portal Login Errors

Incident Report for Rebuy

Postmortem

Description:

On January 6th at approximately 4:10 PM ET an update aimed at improving security caused a temporary disruption, affecting some user logins for approximately 6 minutes. The issue was linked to unexpected behavior in the system's connection to our Redis database, crucial for authentication.

Root Cause:
The update unintentionally allowed operations in production environments that were unnecessary, combined with temporary Redis connection issues, which impacted some user logins.

Resolution:
We reverted the changes to restore service stability.

Next Steps:
We are implementing additional safeguards and better error handling to prevent similar issues from arising in the future. We will then re-deploy the security change after the additional tests have been complete.

Posted Jan 08, 2026 - 15:21 EST

Resolved

We experienced a brief issue where some users encountered an internal error message upon login, preventing access to the system. The team quickly identified and resolved the issue, with the total impact lasting approximately 6 minutes.
Posted Jan 06, 2026 - 16:00 EST