Smart Cart Errors

Incident Report for Rebuy

Postmortem

Incident Summary:
On October 27, 2025, some merchants experienced an issue where their Smart Cart failed to open. This occurred shortly after the release of a new feature designed to support nested cart items in Smart Cart V2. The feature enables merchants to display parent-child product relationships (such as bundles or configurable products) directly within the Smart Cart, improving consistency between the cart and checkout experience.

Root Cause:
The issue stemmed from a missing optionality check in the new nested cart item functionality. The shared cart file (Cart.js) is used by both Smart Cart V1 and V2. The new code called a function, nestedCartItemsEnabled(), that only exists in V2. Because this function does not exist in V1, the call caused a JavaScript error that prevented the Smart Cart from loading for merchants still using the legacy version.

Resolution:
A fix was implemented by adding an optionality check to ensure the function is only executed when present. This change restored functionality for all merchants using Smart Cart V1, while maintaining the new nested cart item capability for V2. The fix was verified locally and across multiple staging environments using different Smart Cart configurations prior to implementation.

Preventive Measures:

  • Added an additional safeguard to confirm version-specific functions are handled appropriately in shared code.
  • Updated internal review processes to ensure smoother compatibility between Smart Cart versions.
Posted Oct 28, 2025 - 15:44 EDT

Resolved

The incident has been resolved and the impacted carts are confirmed functional once again. Our team will investigate the root cause and share the findings in this incident once available. Thank you for your patience.
Posted Oct 27, 2025 - 13:57 EDT

Monitoring

A fix has been implemented and the errors have subsided. We are monitoring for any further issues.
Posted Oct 27, 2025 - 13:52 EDT

Identified

Some customers are seeing issues concerning Smart Cart not loading properly. Our team is aware and working on a solution.
Posted Oct 27, 2025 - 13:49 EDT
This incident affected: Cart & Merchandising (Smart Cart).